The Kotlin programming language (https://kotlinlang.org/).

Backend: pants.backend.experimental.kotlin
Config section: [kotlin]

Basic options

version_for_resolve

--kotlin-version-for-resolve="{'key1': val1, 'key2': val2, ...}"
PANTS_KOTLIN_VERSION_FOR_RESOLVE
default: {}

A dictionary mapping the name of a resolve to the Kotlin version to use for all Kotlin targets consuming that resolve.


Advanced options

None

Deprecated options

None


Did this page help you?