HomeDocs
DocsCommunityTestimonialsUsersGitHubTwitterBlogJobsTermsPrivacyCookies
TermsPrivacyCookies

The Pytype utility for typechecking Python code (https://github.com/google/pytype).

Backend: pants.backend.experimental.python.typecheck.pytype
Config section: [pytype]

Basic options

skip

--[no-]pytype-skip

PANTS_PYTYPE_SKIP

default: False

If true, don't use Pytype when running pants check.


args

--pytype-args="[<shell_str>, <shell_str>, ...]"

PANTS_PYTYPE_ARGS

default: []

Arguments to pass directly to Pytype, e.g. --pytype-args='--version'.


config

--pytype-config=<file_option>

PANTS_PYTYPE_CONFIG

default: None

Path to an toml config file understood by Pytype (https://github.com/google/pytype#config-file).


Advanced options

install_from_resolve

--pytype-install-from-resolve=<str>

PANTS_PYTYPE_INSTALL_FROM_RESOLVE

default: None

If specified, install the tool using the lockfile for this named resolve.

This resolve must be defined in [python].resolves, as described in Third-party dependencies.

The resolve's entire lockfile will be installed, unless specific requirements are listed via the requirements option, in which case only those requirements will be installed. This is useful if you don't want to invalidate the tool's outputs when the resolve incurs changes to unrelated requirements.

If unspecified, and the lockfile option is unset, the tool will be installed using the default lockfile shipped with Pants.

If unspecified, and the lockfile option is set, the tool will use the custom pytype "tool lockfile" generated from the version and extra_requirements options. But note that this mechanism is deprecated.


requirements

--pytype-requirements="['<str>', '<str>', ...]"

PANTS_PYTYPE_REQUIREMENTS

default: []

If install_from_resolve is specified, install these requirements, at the versions provided by the specified resolve's lockfile.

Values can be pip-style requirements (e.g., tool or tool==1.2.3 or tool>=1.2.3), or addresses of python_requirement targets (or targets that generate or depend on python_requirement targets).

The lockfile will be validated against the requirements - if a lockfile doesn't provide the requirement (at a suitable version, if the requirement specifies version constraints) Pants will error.

If unspecified, install the entire lockfile.


interpreter_constraints

--pytype-interpreter-constraints="['<str>', '<str>', ...]"

PANTS_PYTYPE_INTERPRETER_CONSTRAINTS

default:
[
  "CPython>=3.7,<3.10"
]

Python interpreter constraints for this tool.


console_script

--pytype-console-script=<str>

PANTS_PYTYPE_CONSOLE_SCRIPT

default: pytype

The console script for the tool. Using this option is generally preferable to (and mutually exclusive with) specifying an --entry-point since console script names have a higher expectation of staying stable across releases of the tool. Usually, you will not want to change this from the default.


entry_point

--pytype-entry-point=<str>

PANTS_PYTYPE_ENTRY_POINT

default: None

The entry point for the tool. Generally you only want to use this option if the tool does not offer a --console-script (which this option is mutually exclusive with). Usually, you will not want to change this from the default.


Deprecated options

None