setuptools

The Python setuptools library (https://github.com/pypa/setuptools).

Config section: [setuptools]

Basic options

None

Advanced options

version

--setuptools-version=<str>
PANTS_SETUPTOOLS_VERSION
default: setuptools>=50.3.0,<57.0

Requirement string for the tool.


extra_requirements

--setuptools-extra-requirements="['<str>', '<str>', ...]"
PANTS_SETUPTOOLS_EXTRA_REQUIREMENTS
default:
[
  "wheel>=0.35.1,<0.37"
]

Any additional requirement strings to use with the tool. This is useful if the tool allows you to install plugins or if you need to constrain a dependency to a certain version.


Deprecated options

None


Did this page help you?