Hey! These docs are for version 2.0, which is no longer officially supported. Click here for the latest version, 2.7!

docformatter

The Python docformatter tool (https://github.com/myint/docformatter).

Config section: [docformatter]

Basic options

--[no-]docformatter-skip
PANTS_DOCFORMATTER_SKIP
skip
default: False
Don't use docformatter when running `./pants fmt` and `./pants lint`.

--docformatter-args="[<shell_str>, <shell_str>, ...]"
PANTS_DOCFORMATTER_ARGS
args
default: []
Arguments to pass directly to docformatter, e.g. `--docformatter-args="--wrap-summaries=100 --pre-summary-newline"`.

Advanced options

--docformatter-version=<str>
PANTS_DOCFORMATTER_VERSION
version
default: docformatter>=1.3.1,<1.4
Requirement string for the tool.

--docformatter-extra-requirements="['<str>', '<str>', ...]"
PANTS_DOCFORMATTER_EXTRA_REQUIREMENTS
extra_requirements
default: []
Any additional requirement strings to use with the tool. This is useful if the tool allows you to install plugins or if you need to constrain a dependency to a certain version.

--docformatter-entry-point=<str>
PANTS_DOCFORMATTER_ENTRY_POINT
entry_point
default: docformatter:main
The main module for the tool. Usually, you will not want to change this from the default.

--docformatter-interpreter-constraints="['<str>', '<str>', ...]"
PANTS_DOCFORMATTER_INTERPRETER_CONSTRAINTS
interpreter_constraints
default:
[
  "CPython==2.7.*",
  "CPython>=3.4,<3.9"
]

Python interpreter constraints for this tool.

Deprecated options

None


Did this page help you?