Hey! These docs are for version 2.0, which is no longer officially supported. Click here for the latest version, 2.7!

The Flake8 Python linter (https://flake8.pycqa.org/).

Config section: [flake8]

Basic options

--[no-]flake8-skip
PANTS_FLAKE8_SKIP
skip
default: False
Don't use Flake8 when running `./pants lint`

--flake8-args="[<shell_str>, <shell_str>, ...]"
PANTS_FLAKE8_ARGS
args
default: []
Arguments to pass directly to Flake8, e.g. `--flake8-args="--ignore E123,W456 --enable-extensions H111"`

Advanced options

--flake8-version=<str>
PANTS_FLAKE8_VERSION
version
default: flake8>=3.7.9,<3.9
Requirement string for the tool.

--flake8-extra-requirements="['<str>', '<str>', ...]"
PANTS_FLAKE8_EXTRA_REQUIREMENTS
extra_requirements
default:
[
  "setuptools<45"
]

Any additional requirement strings to use with the tool. This is useful if the tool allows you to install plugins or if you need to constrain a dependency to a certain version.

--flake8-entry-point=<str>
PANTS_FLAKE8_ENTRY_POINT
entry_point
default: flake8
The main module for the tool. Usually, you will not want to change this from the default.

--flake8-config=<file_option>
PANTS_FLAKE8_CONFIG
config
default: None
Path to `.flake8` or alternative Flake8 config file

Deprecated options

--flake8-interpreter-constraints="['<str>', '<str>', ...]"
PANTS_FLAKE8_INTERPRETER_CONSTRAINTS
interpreter_constraints
default: []
Deprecated, will be removed in version: 2.1.0.dev0
This option no longer does anything, as Pants auto-configures the interpreter constraints for flake8 based on your code's interpreter constraints.
Python interpreter constraints for this tool.


Did this page help you?