Hey! These docs are for version 2.0, which is no longer officially supported. Click here for the latest version, 2.7!

The IPython enhanced REPL (https://ipython.org/).

Config section: [ipython]

Basic options

None

Advanced options

--ipython-version=<str>
PANTS_IPYTHON_VERSION
version
default: ipython==7.16.1
Requirement string for the tool.

--ipython-extra-requirements="['<str>', '<str>', ...]"
PANTS_IPYTHON_EXTRA_REQUIREMENTS
extra_requirements
default: []
Any additional requirement strings to use with the tool. This is useful if the tool allows you to install plugins or if you need to constrain a dependency to a certain version.

--ipython-entry-point=<str>
PANTS_IPYTHON_ENTRY_POINT
entry_point
default: IPython:start_ipython
The main module for the tool. Usually, you will not want to change this from the default.

--[no-]ipython-ignore-cwd
PANTS_IPYTHON_IGNORE_CWD
ignore_cwd
default: True
Whether to tell IPython not to put the CWD on the import path. Normally you want this to be True, so that imports come from the hermetic environment Pants creates. However IPython<7.13.0 doesn't support this option, so if you're using an earlier version (e.g., because you have Python 2.7 code) then you will need to set this to False, and you may have issues with imports from your CWD shading the hermetic environment.

Deprecated options

--ipython-interpreter-constraints="['<str>', '<str>', ...]"
PANTS_IPYTHON_INTERPRETER_CONSTRAINTS
interpreter_constraints
default: []
Deprecated, will be removed in version: 2.1.0.dev0
This option no longer does anything, as Pants auto-configures the interpreter constraints for ipython based on your code's interpreter constraints.
Python interpreter constraints for this tool.


Did this page help you?