Hey! These docs are for version 2.0, which is no longer officially supported. Click here for the latest version, 2.7!

The MyPy Python type checker (http://mypy-lang.org/).

Config section: [mypy]

Basic options

--[no-]mypy-skip
PANTS_MYPY_SKIP
skip
default: False
Don't use MyPy when running `./pants lint`.

--mypy-args="[<shell_str>, <shell_str>, ...]"
PANTS_MYPY_ARGS
args
default: []
Arguments to pass directly to mypy, e.g. `--mypy-args="--python-version 3.7 --disallow-any-expr"`

Advanced options

--mypy-version=<str>
PANTS_MYPY_VERSION
version
default: mypy==0.782
Requirement string for the tool.

--mypy-extra-requirements="['<str>', '<str>', ...]"
PANTS_MYPY_EXTRA_REQUIREMENTS
extra_requirements
default: []
Any additional requirement strings to use with the tool. This is useful if the tool allows you to install plugins or if you need to constrain a dependency to a certain version.

--mypy-entry-point=<str>
PANTS_MYPY_ENTRY_POINT
entry_point
default: mypy
The main module for the tool. Usually, you will not want to change this from the default.

--mypy-interpreter-constraints="['<str>', '<str>', ...]"
PANTS_MYPY_INTERPRETER_CONSTRAINTS
interpreter_constraints
default:
[
  "CPython>=3.6"
]

Python interpreter constraints for this tool.

--mypy-config=<file_option>
PANTS_MYPY_CONFIG
config
default: None
Path to `mypy.ini` or alternative MyPy config file

--mypy-source-plugins="[<target_option>, <target_option>, ...]"
PANTS_MYPY_SOURCE_PLUGINS
source_plugins
default: []
An optional list of `mypy_source_plugin` target addresses. This allows you to load custom plugins defined in source code. Run `./pants help mypy_source_plugin` for instructions, including how to load third-party plugins.

Deprecated options

None


Did this page help you?