Hey! These docs are for version 2.0, which is no longer officially supported. Click here for the latest version, 2.7!

The PyLint linter for Python code (https://www.pylint.org/).

Config section: [pylint]

Basic options

--[no-]pylint-skip
PANTS_PYLINT_SKIP
skip
default: False
Don't use Pylint when running `./pants lint`

--pylint-args="[<shell_str>, <shell_str>, ...]"
PANTS_PYLINT_ARGS
args
default: []
Arguments to pass directly to Pylint, e.g. `--pylint-args="--ignore=foo.py,bar.py --disable=C0330,W0311"`

Advanced options

--pylint-version=<str>
PANTS_PYLINT_VERSION
version
default: pylint>=2.4.4,<2.5
Requirement string for the tool.

--pylint-extra-requirements="['<str>', '<str>', ...]"
PANTS_PYLINT_EXTRA_REQUIREMENTS
extra_requirements
default: []
Any additional requirement strings to use with the tool. This is useful if the tool allows you to install plugins or if you need to constrain a dependency to a certain version.

--pylint-entry-point=<str>
PANTS_PYLINT_ENTRY_POINT
entry_point
default: pylint
The main module for the tool. Usually, you will not want to change this from the default.

--pylint-config=<file_option>
PANTS_PYLINT_CONFIG
config
default: None
Path to `pylintrc` or alternative Pylint config file

--pylint-source-plugins="[<target_option>, <target_option>, ...]"
PANTS_PYLINT_SOURCE_PLUGINS
source_plugins
default: []
An optional list of `pylint_source_plugin` target addresses. This allows you to load custom plugins defined in source code. Run `./pants help pylint_source_plugin` for instructions, including how to load third-party plugins.

Deprecated options

--pylint-interpreter-constraints="['<str>', '<str>', ...]"
PANTS_PYLINT_INTERPRETER_CONSTRAINTS
interpreter_constraints
default: []
Deprecated, will be removed in version: 2.1.0.dev0
This option no longer does anything, as Pants auto-configures the interpreter constraints for pylint based on your code's interpreter constraints.
Python interpreter constraints for this tool.


Did this page help you?