Hey! These docs are for version 2.0, which is no longer officially supported. Click here for the latest version, 2.7!

python-setup

A Python environment.

Config section: [python-setup]

Basic options

None

Advanced options

--python-setup-interpreter-constraints="[<requirement>, <requirement>, ...]"
PANTS_PYTHON_SETUP_INTERPRETER_CONSTRAINTS
interpreter_constraints
default:
[
  "CPython>=3.6"
]

Constrain the selected Python interpreter. Specify with requirement syntax, e.g. 'CPython>=2.7,<3' (A CPython interpreter with version >=2.7 AND version <3)or 'PyPy' (A pypy interpreter of any version). Multiple constraint strings will be ORed together. These constraints are used as the default value for the `compatibility` field of Python targets.

--python-setup-requirement-constraints=<file_option>
PANTS_PYTHON_SETUP_REQUIREMENT_CONSTRAINTS
requirement_constraints
default: None
When resolving third-party requirements, use this constraints file to determine which versions to use. See https://pip.pypa.io/en/stable/user_guide/#constraints-files for more information on the format of constraint files and how constraints are applied in Pex and pip.

--python-setup-resolve-all-constraints=<ResolveAllConstraintsOption>
PANTS_PYTHON_SETUP_RESOLVE_ALL_CONSTRAINTS
resolve_all_constraints
one of: never, nondeployables, always
default: nondeployables
If set, and the requirements of the code being operated on are a subset of the constraints file, then the entire constraints file will be used instead of the subset. If unset, or any requirement of the code being operated on is not in the constraints file, each subset will be independently resolved as needed, which is more correct - work is only invalidated if a requirement it actually depends on changes - but also a lot slower, due to the extra resolving.
  • never will always use proper subsets, regardless of the goal being run.
  • nondeployables will use proper subsets for ./pants package, but otherwise attempt to use a single resolve.
  • always will always attempt to use a single resolve.

Requires [python-setup].requirement_constraints to be set.


--python-setup-interpreter-search-paths="[<binary-paths>, <binary-paths>, ...]"
PANTS_PYTHON_SETUP_INTERPRETER_SEARCH_PATHS
interpreter_search_paths
default:
[
  "<PYENV>",
  "<PATH>"
]

A list of paths to search for Python interpreters that match your project's interpreter constraints. You can specify absolute paths to interpreter binaries and/or to directories containing interpreter binaries. The order of entries does not matter. The following special strings are supported:
  • "<PATH>", the contents of the PATH env var
  • "<PYENV>", all Python versions under $(pyenv root)/versions
  • "<PYENV_LOCAL>", the Pyenv interpreter with the version in BUILD_ROOT/.python-version
  • "<PEXRC>", paths in the PEX_PYTHON_PATH variable in /etc/pexrc or ~/.pexrc

--python-setup-resolver-manylinux=<str>
PANTS_PYTHON_SETUP_RESOLVER_MANYLINUX
resolver_manylinux
default: manylinux2014
Whether to allow resolution of manylinux wheels when resolving requirements for foreign linux platforms. The value should be a manylinux platform upper bound, e.g.: 'manylinux2010', or else the string 'no' to disallow.

--python-setup-resolver-jobs=<int>
PANTS_PYTHON_SETUP_RESOLVER_JOBS
resolver_jobs
default: 6
The maximum number of concurrent jobs to build wheels with. Because Pants can run multiple subprocesses in parallel, the maximum total parallelism will be `--process-execution-{local,remote}-parallelism x --python-setup-resolver-jobs`. Setting this option higher may result in better parallelism, but, if set too high, may result in starvation and Out of Memory errors.

--python-setup-resolver-http-cache-ttl=<int>
PANTS_PYTHON_SETUP_RESOLVER_HTTP_CACHE_TTL
resolver_http_cache_ttl
default: 3600
The maximum time (in seconds) for items in the HTTP cache. When the cache expires,the PEX resolver will make network requests to see if new versions of your requirements are available.

Deprecated options

--python-setup-platforms="[<platform>, <platform>, ...]"
PANTS_PYTHON_SETUP_PLATFORMS
platforms
default:
[
  "current"
]

Deprecated, will be removed in version: 2.1.0.dev0
The option `--python-setup-platforms` does not do anything anymore. Instead, explicitly set the `platforms` field on each `pex_binary` target.
A list of platforms to be supported by this Python environment. Each platformis a string, as returned by pkg_resources.get_supported_platform().

--python-setup-interpreter-cache-dir=<dir>
PANTS_PYTHON_SETUP_INTERPRETER_CACHE_DIR
interpreter_cache_dir
default: None
Deprecated, will be removed in version: 2.1.0.dev0
The option `--python-setup-interpreter-cache-dir` does not do anything anymore.Instead, use the global option `--named-caches-dir`.
The parent directory for the interpreter cache. If unspecified, a standard path under the workdir is used.

--python-setup-resolver-cache-dir=<dir>
PANTS_PYTHON_SETUP_RESOLVER_CACHE_DIR
resolver_cache_dir
default: None
Deprecated, will be removed in version: 2.1.0.dev0
The option `--python-setup-resolver-cache-dir` does not do anything anymore. Instead, use the global option `--named-caches-dir`.
The parent directory for the requirement resolver cache. If unspecified, a standard path under the workdir is used.

--[no-]python-setup-resolver-allow-prereleases
PANTS_PYTHON_SETUP_RESOLVER_ALLOW_PRERELEASES
resolver_allow_prereleases
default: None
Deprecated, will be removed in version: 2.1.0.dev0
The option `--python-setup-resolver-allow-prereleases` does not no anything. To use a pre-release, explicitly use that pre-release version in your requirement string, e.g. `my_dist==99.0.dev0`.
Whether to include pre-releases when resolving requirements.


Did this page help you?