Hey! These docs are for version 2.0, which is no longer officially supported. Click here for the latest version, 2.7!

setuptools

The Python setuptools library (https://github.com/pypa/setuptools).

Config section: [setuptools]

Basic options

None

Advanced options

--setuptools-version=<str>
PANTS_SETUPTOOLS_VERSION
version
default: setuptools>=50.3.0,<50.4
Requirement string for the tool.

--setuptools-extra-requirements="['<str>', '<str>', ...]"
PANTS_SETUPTOOLS_EXTRA_REQUIREMENTS
extra_requirements
default:
[
  "wheel==0.35.1"
]

Any additional requirement strings to use with the tool. This is useful if the tool allows you to install plugins or if you need to constrain a dependency to a certain version.

--setuptools-entry-point=<str>
PANTS_SETUPTOOLS_ENTRY_POINT
entry_point
default: None
The main module for the tool. Usually, you will not want to change this from the default.

--setuptools-interpreter-constraints="['<str>', '<str>', ...]"
PANTS_SETUPTOOLS_INTERPRETER_CONSTRAINTS
interpreter_constraints
default:
[
  "CPython>=3.5"
]

Python interpreter constraints for this tool.

Deprecated options

None


Did this page help you?