Hey! These docs are for version 2.0, which is no longer officially supported. Click here for the latest version, 2.7!
./pants validate [args]

Validate sources against regexes.

Config section: [validate]

Basic options

--validate-detail-level=<DetailLevel>
PANTS_VALIDATE_DETAIL_LEVEL
detail_level
one of: none, summary, nonmatching, names, all
default: nonmatching
How much detail to emit to the console.

Advanced options

None

Deprecated options

None

Related subsystems

download-pex-bin, grpc_python_plugin, pex, protoc, python-native-code, python-protobuf, python-repos, python-setup, source, sourcefile-validation, subprocess-environment, validate


Did this page help you?