Hey! These docs are for version 2.0, which is no longer officially supported. Click here for the latest version, 2.7!

Some highlights:

  • Replaces the globs() syntax in the sources field in BUILD files with a simpler list of file names and globs. See https://groups.google.com/forum/#!topic/pants-devel/3nmdSeyvwU0.
  • Adds support for using file arguments.
  • Adds Bandit security linter for Python.
  • Configures Python 3.6+ as the default Python version.
  • Adds ./pants test --debug to run tests interactively.

See here for a detailed change log.


Did this page help you?