Hey! These docs are for version 2.0, which is no longer officially supported. Click here for the latest version, 2.7!

Some highlights:

  • The run, test, and setup-py goals support passing arguments via --, e.g. ./pants test test_app.py -- -vv -k test_demo.
  • Python linters can now run on both Python 2 and Python 3 targets in the same run. See lint.
  • Added support for Pylint source plugins. See Linters and formatters.
  • Added the filter goal. See Project introspection.
  • Code generators will now automatically add the generator's runtime dependencies. See Protobuf.
  • Resolving requirements should be a bit faster thanks to better caching.
  • Improved the Pants daemon (pantsd). It should now be safe to turn on with the option enable_pantsd = true in the [GLOBAL] scope. Pantsd substantially improves Pants performance and caching.
  • Removed deprecated source field in BUILD files in favor of sources.
  • Removed several deprecated V1 backends and plugins.

See here for a detailed change log.


Did this page help you?