Hey! These docs are for version 2.10, which is no longer officially supported. Click here for the latest version, 2.13!

scalafmt (https://scalameta.org/scalafmt/)

Backend: pants.backend.experimental.scala.lint.scalafmt
Config section: [scalafmt]

Basic options

skip

--[no-]scalafmt-skip
PANTS_SCALAFMT_SKIP
default: False

Don't use scalafmt when running ./pants fmt and ./pants lint


Advanced options

version

--scalafmt-version=<str>
PANTS_SCALAFMT_VERSION
default: 3.2.1

Version string for the tool. This is available for substitution in the [scalafmt].artifacts option by including the string {version}.


artifacts

--scalafmt-artifacts="['<str>', '<str>', ...]"
PANTS_SCALAFMT_ARTIFACTS
default:
[
  "org.scalameta:scalafmt-cli_2.13:{version}"
]

Artifact requirements for this tool using specified as either the address of a jvm_artifact target or, alternatively, as a colon-separated Maven coordinates (e.g., group:name:version). For Maven coordinates, the string {version} version will be substituted with the value of the [scalafmt].version option.


lockfile

--scalafmt-lockfile=<str>
PANTS_SCALAFMT_LOCKFILE
default: <default>

Path to a lockfile used for installing the tool.

Set to the string <default> to use a lockfile provided by Pants, so long as you have not changed the --version option. See https://github.com/pantsbuild/pants/blob/release_2.10.1rc1/src/python/pants/backend/scala/lint/scalafmt/scalafmt.default.lockfile.txt for the default lockfile contents.

To use a custom lockfile, set this option to a file path relative to the build root, then run ./pants jvm-generate-lockfiles --resolve=scalafmt.


Deprecated options

None


Did this page help you?