HomeDocs
DocsCommunityTestimonialsUsersGitHubTwitterBlogJobsTermsPrivacyCookies
TermsPrivacyCookies

The Pylint linter for Python code (https://www.pylint.org/).

Backend: pants.backend.python.lint.pylint
Config section: [pylint]

Basic options

skip

--[no-]pylint-skip

PANTS_PYLINT_SKIP

default: False

If true, don't use Pylint when running pants lint.


args

--pylint-args="[<shell_str>, <shell_str>, ...]"

PANTS_PYLINT_ARGS

default: []

Arguments to pass directly to Pylint, e.g. --pylint-args='--ignore=foo.py,bar.py --disable=C0330,W0311'.


Advanced options

install_from_resolve

--pylint-install-from-resolve=<str>

PANTS_PYLINT_INSTALL_FROM_RESOLVE

default: None

If specified, install the tool using the lockfile for this named resolve.

This resolve must be defined in [python].resolves, as described in Third-party dependencies.

The resolve's entire lockfile will be installed, unless specific requirements are listed via the requirements option, in which case only those requirements will be installed. This is useful if you don't want to invalidate the tool's outputs when the resolve incurs changes to unrelated requirements.

If unspecified, and the lockfile option is unset, the tool will be installed using the default lockfile shipped with Pants.

If unspecified, and the lockfile option is set, the tool will use the custom pylint "tool lockfile" generated from the version and extra_requirements options. But note that this mechanism is deprecated.


requirements

--pylint-requirements="['<str>', '<str>', ...]"

PANTS_PYLINT_REQUIREMENTS

default: []

If install_from_resolve is specified, install these requirements, at the versions provided by the specified resolve's lockfile.

Values can be pip-style requirements (e.g., tool or tool==1.2.3 or tool>=1.2.3), or addresses of python_requirement targets (or targets that generate or depend on python_requirement targets).

The lockfile will be validated against the requirements - if a lockfile doesn't provide the requirement (at a suitable version, if the requirement specifies version constraints) Pants will error.

If unspecified, install the entire lockfile.


console_script

--pylint-console-script=<str>

PANTS_PYLINT_CONSOLE_SCRIPT

default: pylint

The console script for the tool. Using this option is generally preferable to (and mutually exclusive with) specifying an --entry-point since console script names have a higher expectation of staying stable across releases of the tool. Usually, you will not want to change this from the default.


entry_point

--pylint-entry-point=<str>

PANTS_PYLINT_ENTRY_POINT

default: None

The entry point for the tool. Generally you only want to use this option if the tool does not offer a --console-script (which this option is mutually exclusive with). Usually, you will not want to change this from the default.


config

--pylint-config=<file_option>

PANTS_PYLINT_CONFIG

default: None

Path to a config file understood by Pylint (http://pylint.pycqa.org/en/latest/user_guide/run.html#command-line-options).

Setting this option will disable [pylint].config_discovery. Use this option if the config is located in a non-standard location.


config_discovery

--[no-]pylint-config-discovery

PANTS_PYLINT_CONFIG_DISCOVERY

default: True

If true, Pants will include any relevant config files during runs (.pylintrc, pylintrc, pyproject.toml, and setup.cfg).

Use [pylint].config instead if your config is in a non-standard location.


source_plugins

--pylint-source-plugins="[<target_option>, <target_option>, ...]"

PANTS_PYLINT_SOURCE_PLUGINS

default: []

An optional list of python_sources target addresses to load first-party plugins.

You must set the plugin's parent directory as a source root. For example, if your plugin is at build-support/pylint/custom_plugin.py, add 'build-support/pylint' to [source].root_patterns in pants.toml. This is necessary for Pants to know how to tell Pylint to discover your plugin. See Source roots

You must also set load-plugins=$module_name in your Pylint config file.

While your plugin's code can depend on other first-party code and third-party requirements, all first-party dependencies of the plugin must live in the same directory or a subdirectory.

To instead load third-party plugins, set the option [pylint].extra_requirements and set the load-plugins option in your Pylint config.

Tip: it's often helpful to define a dedicated 'resolve' via [python].resolves for your Pylint plugins such as 'pylint-plugins' so that the third-party requirements used by your plugin, like pylint, do not mix with the rest of your project. Read that option's help message for more info on resolves.


Deprecated options

version

--pylint-version=<str>

PANTS_PYLINT_VERSION

default: pylint>=2.13.0,<3

Deprecated, is scheduled to be removed in version: 2.18.0.dev1.
Custom tool versions are now installed from named resolves, as described at [Lockfiles](doc:python-lockfiles).


Requirement string for the tool.


extra_requirements

--pylint-extra-requirements="['<str>', '<str>', ...]"

PANTS_PYLINT_EXTRA_REQUIREMENTS

default: []

Deprecated, is scheduled to be removed in version: 2.18.0.dev1.
Custom tool versions are now installed from named resolves, as described at [Lockfiles](doc:python-lockfiles).


Any additional requirement strings to use with the tool. This is useful if the tool allows you to install plugins or if you need to constrain a dependency to a certain version.


lockfile

--pylint-lockfile=<str>

PANTS_PYLINT_LOCKFILE

default: <default>

Deprecated, is scheduled to be removed in version: 2.18.0.dev0.
Custom tool versions are now installed from named resolves, as described at [Lockfiles](doc:python-lockfiles).

  1. If you have an existing resolve that includes the requirements for this tool,
    you can set `[pylint].install_from_resolve = "<resolve name>".
    This may be the case if the tool also provides a runtime library, and you want
    to specify the version in just one place.
  2. If not, you can set up a new resolve as described at the link above.

Either way, the resolve you choose should provide the requirements currently set by the version and extra-requirements options for this tool, which you can see by running pants help-advanced pylint.



Path to a lockfile used for installing the tool.

Set to the string <default> to use a lockfile provided by Pants, so long as you have not changed the --version and --extra-requirements options, and the tool's interpreter constraints are compatible with the default. Pants will error or warn if the lockfile is not compatible (controlled by [python].invalid_lockfile_behavior). See https://github.com/pantsbuild/pants/blob/release_2.16.1rc4/src/python/pants/backend/python/lint/pylint/pylint.lock for the default lockfile contents.

Set to the string <none> to opt out of using a lockfile. We do not recommend this, though, as lockfiles are essential for reproducible builds and supply-chain security.

To use a custom lockfile, set this option to a file path relative to the build root, then run pants generate-lockfiles --resolve=pylint.

Alternatively, you can set this option to the path to a custom lockfile using pip's requirements.txt-style, ideally with --hash. Set [python].invalid_lockfile_behavior = 'ignore' so that Pants does not complain about missing lockfile headers.


export

--[no-]pylint-export

PANTS_PYLINT_EXPORT

default: True

Deprecated, is scheduled to be removed in version: 2.18.0.dev0.
Use the export goal's --resolve option to select tools to export, instead of using this option to exempt a tool from export-by-default.


If true, export a virtual environment with Pylint when running pants export.

This can be useful, for example, with IDE integrations to point your editor to the tool's binary.