HomeDocs
DocsCommunityTestimonialsUsersGitHubTwitterBlogJobsTermsPrivacyCookies
TermsPrivacyCookies

The utility for publishing Python distributions to PyPI and other Python repositories.

Backend: pants.backend.experimental.python
Config section: [twine]

Basic options

skip

--[no-]twine-skip

PANTS_TWINE_SKIP

default: False

If true, don't use Twine when running pants publish.


args

--twine-args="[<shell_str>, <shell_str>, ...]"

PANTS_TWINE_ARGS

default: []

Arguments to pass directly to Twine, e.g. --twine-args='--skip-existing'.


Advanced options

install_from_resolve

--twine-install-from-resolve=<str>

PANTS_TWINE_INSTALL_FROM_RESOLVE

default: None

If specified, install the tool using the lockfile for this named resolve.

This resolve must be defined in [python].resolves, as described in Third-party dependencies.

The resolve's entire lockfile will be installed, unless specific requirements are listed via the requirements option, in which case only those requirements will be installed. This is useful if you don't want to invalidate the tool's outputs when the resolve incurs changes to unrelated requirements.

If unspecified, and the lockfile option is unset, the tool will be installed using the default lockfile shipped with Pants.

If unspecified, and the lockfile option is set, the tool will use the custom twine "tool lockfile" generated from the version and extra_requirements options. But note that this mechanism is deprecated.


requirements

--twine-requirements="['<str>', '<str>', ...]"

PANTS_TWINE_REQUIREMENTS

default: []

If install_from_resolve is specified, install these requirements, at the versions provided by the specified resolve's lockfile.

Values can be pip-style requirements (e.g., tool or tool==1.2.3 or tool>=1.2.3), or addresses of python_requirement targets (or targets that generate or depend on python_requirement targets).

The lockfile will be validated against the requirements - if a lockfile doesn't provide the requirement (at a suitable version, if the requirement specifies version constraints) Pants will error.

If unspecified, install the entire lockfile.


interpreter_constraints

--twine-interpreter-constraints="['<str>', '<str>', ...]"

PANTS_TWINE_INTERPRETER_CONSTRAINTS

default:
[
  "CPython>=3.7,<4"
]

Python interpreter constraints for this tool.


console_script

--twine-console-script=<str>

PANTS_TWINE_CONSOLE_SCRIPT

default: twine

The console script for the tool. Using this option is generally preferable to (and mutually exclusive with) specifying an --entry-point since console script names have a higher expectation of staying stable across releases of the tool. Usually, you will not want to change this from the default.


entry_point

--twine-entry-point=<str>

PANTS_TWINE_ENTRY_POINT

default: None

The entry point for the tool. Generally you only want to use this option if the tool does not offer a --console-script (which this option is mutually exclusive with). Usually, you will not want to change this from the default.


config

--twine-config=<file_option>

PANTS_TWINE_CONFIG

default: None

Path to a .pypirc config file to use. (https://packaging.python.org/specifications/pypirc/)

Setting this option will disable [twine].config_discovery. Use this option if the config is located in a non-standard location.


config_discovery

--[no-]twine-config-discovery

PANTS_TWINE_CONFIG_DISCOVERY

default: True

If true, Pants will include all relevant config files during runs (.pypirc).

Use [twine].config instead if your config is in a non-standard location.


ca_certs_path

--twine-ca-certs-path=<str>

PANTS_TWINE_CA_CERTS_PATH

default: <inherit>

Path to a file containing PEM-format CA certificates used for verifying secure connections when publishing python distributions.

Uses the value from [GLOBAL].ca_certs_path by default. Set to "<none>" to not use any certificates.

Even when using the docker_environment and remote_environment targets, this path will be read from the local host, and those certs will be used in the environment.

This option cannot be overridden via environment targets, so if you need a different value than what the rest of your organization is using, override the value via an environment variable, CLI argument, or .pants.rc file. See Options.


Deprecated options

version

--twine-version=<str>

PANTS_TWINE_VERSION

default: twine>=4,<5

Deprecated, is scheduled to be removed in version: 2.18.0.dev1.
Custom tool versions are now installed from named resolves, as described at [Lockfiles](doc:python-lockfiles).


Requirement string for the tool.


extra_requirements

--twine-extra-requirements="['<str>', '<str>', ...]"

PANTS_TWINE_EXTRA_REQUIREMENTS

default:
[
  "colorama>=0.4.3"
]

Deprecated, is scheduled to be removed in version: 2.18.0.dev1.
Custom tool versions are now installed from named resolves, as described at [Lockfiles](doc:python-lockfiles).


Any additional requirement strings to use with the tool. This is useful if the tool allows you to install plugins or if you need to constrain a dependency to a certain version.


lockfile

--twine-lockfile=<str>

PANTS_TWINE_LOCKFILE

default: <default>

Deprecated, is scheduled to be removed in version: 2.18.0.dev0.
Custom tool versions are now installed from named resolves, as described at [Lockfiles](doc:python-lockfiles).

  1. If you have an existing resolve that includes the requirements for this tool,
    you can set `[twine].install_from_resolve = "<resolve name>".
    This may be the case if the tool also provides a runtime library, and you want
    to specify the version in just one place.
  2. If not, you can set up a new resolve as described at the link above.

Either way, the resolve you choose should provide the requirements currently set by the version and extra-requirements options for this tool, which you can see by running pants help-advanced twine.



Path to a lockfile used for installing the tool.

Set to the string <default> to use a lockfile provided by Pants, so long as you have not changed the --version and --extra-requirements options, and the tool's interpreter constraints are compatible with the default. Pants will error or warn if the lockfile is not compatible (controlled by [python].invalid_lockfile_behavior). See https://github.com/pantsbuild/pants/blob/release_2.16.1rc4/src/python/pants/backend/python/subsystems/twine.lock for the default lockfile contents.

Set to the string <none> to opt out of using a lockfile. We do not recommend this, though, as lockfiles are essential for reproducible builds and supply-chain security.

To use a custom lockfile, set this option to a file path relative to the build root, then run pants generate-lockfiles --resolve=twine.

Alternatively, you can set this option to the path to a custom lockfile using pip's requirements.txt-style, ideally with --hash. Set [python].invalid_lockfile_behavior = 'ignore' so that Pants does not complain about missing lockfile headers.